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Legal information 
Warning notice system 

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent 
damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert 
symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are 
graded according to the degree of danger. 

 DANGER 
indicates that death or severe personal injury will result if proper precautions are not taken. 

 

 WARNING 
indicates that death or severe personal injury may result if proper precautions are not taken. 

 

 CAUTION 
indicates that minor personal injury can result if proper precautions are not taken. 

 

 NOTICE 
indicates that property damage can result if proper precautions are not taken. 

If more than one degree of danger is present, the warning notice representing the highest degree of danger will 
be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to 
property damage. 

Qualified Personnel 
The product/system described in this documentation may be operated only by personnel qualified for the specific 
task in accordance with the relevant documentation, in particular its warning notices and safety instructions. 
Qualified personnel are those who, based on their training and experience, are capable of identifying risks and 
avoiding potential hazards when working with these products/systems. 

Proper use of Siemens products 
Note the following: 

 WARNING 
Siemens products may only be used for the applications described in the catalog and in the relevant technical 
documentation. If products and components from other manufacturers are used, these must be recommended 
or approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and 
maintenance are required to ensure that the products operate safely and without any problems. The permissible 
ambient conditions must be complied with. The information in the relevant documentation must be observed. 

Trademarks 
All names identified by ® are registered trademarks of Siemens AG. The remaining trademarks in this publication 
may be trademarks whose use by third parties for their own purposes could violate the rights of the owner. 

Disclaimer of Liability 
We have reviewed the contents of this publication to ensure consistency with the hardware and software 
described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the 
information in this publication is reviewed regularly and any necessary corrections are included in subsequent 
editions. 
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 Introduction 1 
 

 

Even in their basic versions, SIMATIC Industry PCs come with optional monitoring functions. 
When used in combination with the appropriate software, the following functions for 
displaying, monitoring and controlling are available:  

● Temperature monitoring (over-temperature, under-temperature or cable break at a 
temperature sensor) 

● Fan monitoring (fan speed too low, fan failure, or a break in a tachometer line) 

● Monitoring of the battery level 

● Monitoring of hard disks with S.M.A.R.T functionality even in a RAID system 

● Watchdog (hardware or software reset of the computer) 

● Operating hours meter (information on the cumulative run time) 

With the SIMATIC IPC DiagMonitor software, you can use these functions for local 
monitoring. You can use the DiagMonitor Management Explorer application for general 
monitoring or DiagMonitor Alarm Manager for notification of individual alarms. 

This documentation describes the functionality of SIMATIC IPC DiagMonitor software.  
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 SIMATIC IPC DiagMonitor software components 2 
 

 

The following components are included in the scope of delivery:  
 
Software Components Explanations 
DMDataEngine  This service returns status information of the monitored device 

components to SIMATIC IPC DiagMonitor 
DMMsgService  This service is responsible for advanced processing of alarms. 
DMAlarmManagerService  This service is responsible for advanced processing of alarms. 
IPCUniDrv  Driver for hardware access. 
DMOPCService  This service is responsible for communication with OPC. 
DMSNMPDataEngine  This service supplies the connection to the monitored stations. 
MiniWeb  This service supplies the monitoring data per HTTP. 
Alarm Manager  Assigns the relevant alarms to executable programs. 
Alarm Display  Lists the individual alarms for acknowledgment. 
Management Explorer  Lists the monitored device components and status in an overview. 

During installation, these components are copied to the system disk and are available for 
startup in the system. 
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 Quick-Start Guide 3 
 

 

The following steps are required to use SIMATIC IPC DiagMonitor monitoring:  

1. Ensure that all the hardware and software requirements are met for the operation of 
SIMATIC IPC DiagMonitor (see section Hardware and software requirements (Page 9) ). 

2. Perform the SIMATIC IPC DiagMonitor installation on the SIMATIC IPC (see section 
Installation (Page 12)).  

3. Start the DiagMonitor Alarm Manager in order to be informed of malfunctioning of the 
monitored device components. 
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 Hardware and software requirements 4 
4.1 Hardware requirements 

Only the following SIEMENS products are supported:  

● SIMATIC IPC227D 

● SIMATIC IPC277D 

● SIMATIC IPC427D 

● SIMATIC IPC477D 

● SIMATIC IPC627D 

● SIMATIC IPC647D 

● SIMATIC IPC677D 

● SIMATIC IPC827D 

● SIMATIC IPC847D 

● SIMATIC IPC227E 

● SIMATIC IPC277E 

● SIMATIC IPC427E 

● SIMATIC IPC477E 

● SIMATIC IPC547E 

● SIMATIC IPC547G 



Hardware and software requirements  
4.2 Software Requirements 
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4.2 Software Requirements 

Requirement 
At least one network adapter with TCP/IP. 

Operating systems 
The SIMATIC IPC DiagMonitor software can be used with the following operating systems:  

● Microsoft Windows Server 2008 R2, 64-bit 

● Microsoft Windows Embedded Standard 7, 32-bit (SIMATIC IPC configuration) 

● Microsoft Windows Embedded Standard 7, 64-bit (SIMATIC IPC configuration) 

● Microsoft Windows 7 Ultimate, 32-bit 

● Microsoft Windows 7 Ultimate, 64-bit 

● Microsoft Windows Server 2012 R2, 64-bit 

● Windows 10 IoT Enterprise LTSB 

Restriction 
Remote monitoring can only be performed via the TCP/IP Internet protocol because the 
employed SNMP protocol is available in this protocol family.  
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4.3 Industrial Security 

Industrial Security 
Siemens provides products and solutions with industrial security functions that support the 
secure operation of plants, systems, machines and networks. 

In order to protect plants, systems, machines and networks against cyber threats, it is 
necessary to implement – and continuously maintain – a holistic, state-of-the-art industrial 
security concept. Siemens’ products and solutions only form one element of such a concept. 

Customer is responsible to prevent unauthorized access to its plants, systems, machines 
and networks. Systems, machines and components should only be connected to the 
enterprise network or the internet if and to the extent necessary and with appropriate security 
measures (e.g. use of firewalls and network segmentation) in place.  

Additionally, Siemens’ guidance on appropriate security measures should be taken into 
account. For more information about industrial security, please visit 
(http://www.siemens.com/industrialsecurity). 

Siemens’ products and solutions undergo continuous development to make them more 
secure. Siemens strongly recommends to apply product updates as soon as available and to 
always use the latest product versions. Use of product versions that are no longer supported, 
and failure to apply latest updates may increase customer’s exposure to cyber threats.  

To stay informed about product updates, subscribe to the Siemens Industrial Security 
RSS Feed under (https://support.industry.siemens.com). 

Disclaimer for third-party software updates 
This product includes third-party software. Siemens AG only provides a warranty for 
updates/patches of the third-party software, if these have been distributed as part of a 
Siemens software update service contract or officially released by Siemens AG. Otherwise, 
updates/patches are undertaken at your own risk. You can find more information about our 
Software Update Service offer on the Internet at Software Update Service 
(http://www.automation.siemens.com/mcms/automation-software/en/software-update-
service). 

Notes on protecting administrator accounts 
A user with administrator privileges has extensive access and manipulation options in the 
system. 

Therefore, ensure there are adequate safeguards for protecting the administrator accounts 
to prevent unauthorized changes. To do this, use secure passwords and a standard user 
account for normal operation. Other measures, such as the use of security policies, should 
be applied as needed. 
 

http://www.siemens.com/industrialsecurity
https://support.industry.siemens.com/
http://www.automation.siemens.com/mcms/automation-software/en/software-update-service
http://www.automation.siemens.com/mcms/automation-software/en/software-update-service
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 Installing and removing the software 5 
5.1 Installation 

Because this installation places entries in the Windows registry and the system folder, it can 
only be performed by someone with administrator rights. 

1. Start Start.exe. 

2. Select the setup language to be used during the installation.  

3. Follow the instructions displayed on the screen. 

Silent installation 

You have the option of installing SIMATIC IPC DiagMonitor without displaying a window 
during the installation process. You cannot make any input during the installation. 

To do this, run the application DMInstManager.exe. 
 

 Note 

Please note that you always need administrator rights to install an application. 
 

5.2 Removal 
As usual in Windows, you uninstall an application via the Control Panel. This SIMATIC IPC 
DiagMonitor name is entered in the software installation list as follows: 

SIMATIC IPC DiagMonitor 

The removal routine removes all components from your system. Your configuration settings 
are maintained.  

Silent removal  

You have the option of uninstalling SIMATIC IPC DiagMonitor without displaying a window 
during the uninstallation process. 

To do this, run the application DMInstManager.exe. 
 

 Note 

Please note that you always need administrator rights to remove an application. 
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 Description of the DiagMonitor Management Explorer 6 
6.1 Starting Management Explorer 

The DiagMonitor Management Explorer can be configured in such a way that the application 
is started automatically when the system starts up. You can enable this feature as follows:  

1. Select the menu command "Options > Settings...". 

2. Select the "Start with Windows session" field. 

3. Click "OK" to confirm the selection.  

DiagMonitor Management Explorer starts automatically the next time the system starts 
up. The application autonomously prevents multiple starts. 

Program window 

The setting and size of the program window are retained during runtime. 

6.2 The Management Explorer 
The DiagMonitor Management Explorer provides a two-pane view similar to the Windows 
Explorer. In the left-hand pane, all the function groups to be monitored are listed in a tree 
structure below the name of the station.  

The right-hand pane of the window shows the individual devices of a function group. These 
can be displayed in various views (see Selecting the view (Page 14)). 

A toolbar is displayed in the program window by default. It can be hidden using the "View" 
menu command.  

● Alarms can be acknowledged with the green check mark. 

● Using the arrow left and arrow right buttons, you can move backwards and forwards 
through the various function groups in much the same way as in an Internet browser. 

6.3 Displaying the properties of a station 
To display the properties of a station, follow these steps:  

1. Right-click on the station in the tree view. 

2. Select the menu command "Properties" from the shortcut menu. 

3. The "Station properties..." window opens and displays information on the station.  
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6.4 Displaying the properties of a group 
To display the properties of a group, follow these steps:  

1. Right-click on the group in the tree view. 

2. Select the menu command "Properties" from the shortcut menu. 

3. The "Group properties..." window opens and displays the number of elements contained.  

6.5 Displaying the properties of an element 
To display the properties of an element, follow these steps:  

1. Right-click on the element in the list view. 

2. Select the menu command "Properties" from the shortcut menu. 

3. The "Element properties..." window opens and displays the main properties of the 
element.  

6.6 Selecting the view 
In the right-hand pane of the program window of the DiagMonitor Management Explorer, you 
can choose between three different representations. You can select these using the "View" 
menu command or the "Standard" toolbar.   

The following views are available:   

● Tiles: The elements of the sensors, for example fans or temperatures are shown in the list 
view graphically in the form of a scale. The values to the left of the scale show the 
permitted high and low limits. The value below the scale is the current value. To the right 
of the scale, there are two pointers. These indicate the maximum or minimum value 
measured up to now. To reset the max/min pointers to the current value, right-click on the 
required element in the list view. Select "Reset interval values" 

● Icons: This view displays large icons and brief status information about the monitored 
devices. 

● Details: This view displays small icons and detailed status information about the 
monitored devices. 

Example of a fan: In the detailed view, apart from the type and current value, you can 
also see the low and high limit of the fan speed. 
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6.7 Interpreting status information in the Management Explorer 
The station is in one of the following statuses: 

● No alarm: 

No maintenance whatsoever is necessary. The station is represented by a computer icon 
in the overview. All monitored device components are working normally. 

● Alarm (red): 

Maintenance work on the respective SIMATIC IPC is required. The color of the station 
icon has changed to red. The function groups that have an alarm are also displayed in 
red. Click on one of these groups to display detailed information in the right-hand pane of 
the program window.  

Example: The CPU temperature of the station is too high --> alarm. Click on the 
"Temperatures" group. In the right-hand pane of the window, you will see an overview of 
all the temperatures of this station. 

● Outgoing alarm (yellow): 

Maintenance work on the respective SIMATIC IPC is required. An alarm was reported 
earlier for a function group, but it is now working normally. The icon color of the device 
has changed from red to yellow. If there is no other device with an alarm, the color of the 
station icon changes to yellow. To display detailed information, click on the relevant 
group.  

Example: The CPU temperature of the station is too high --> alarm. By eliminating the 
cause of the problem or if the CPU temperature returns to normal on its own --> Outgoing 
Alarm. Click on the "Temperatures" group. In the right-hand pane of the window, you will 
see an overview of all the temperatures of this station. 

● Acknowledged alarm (red icon with green check mark): 

Maintenance work on the respective SIMATIC IPC is required. The alarm from a function 
group was acknowledged, the problem, however, remains. A green check mark is added 
to the red icon in the right-hand pain of the window. To display detailed information, click 
on the relevant group.  

6.8 Acknowledging alarms in the Management Explorer 
If an alarm occurs, the status of the function group or the station changes back to "No alarm" 
only after the problem has been cleared and the alarm has been acknowledged.  

To acknowledge an alarm on a specific function group in the Management Explorer, switch 
to the relevant function group. Now, right-click on the function group involved in the right 
pane of the window You can acknowledge an alarm using the displayed shortcut menu. To 
acknowledge several alarms within a function group or the entire station, you can use the 
same procedure in the tree view.  

Example: Alarms are displayed for a fan and the CPU temperature. You want to 
acknowledge both at the same time. Right-click on the name of the station. Then select 
"Acknowledge alarm" in the shortcut menu.  
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6.9 The "Properties..." Window 
This window displays the main properties of a selected station, group or element.  

Special features of groups: 

● Sensors: For fans or temperatures, the current value and the low and high limit value are 
displayed. 

● Displays: For LEDs and optional 7-segment displays, you can link an alarm with an 
element in the "Alarm mapping" tab. See Mapping an alarm to a display (Page 16). 

● Watchdog: You can set a timeout value and options for watchdog operation. See 
Configuring the watchdog (Page 17). 

● Station: A station description can be stored. 

● Hard disks: Limits can be defined for the free space of the partitions. 

6.10 Mapping an alarm to a display 
The DiagMonitor Management Explorer allows you to map occurring alarms to an LED or the 
optional 7-segment display. The mapping can be done for the station or an individual 
function group. If, for example, the fan generates an alarm, this can be recognized by an 
LED lighting up.  

 

 Note 

The interrupt assignment is possible only for devices with a 7-segment display or LEDs. 
 

To map an alarm, follow these steps: 

1. Select the "LEDs" group in the tree view of the Management Explorer. 

2. In the right pane of the window, select the required output target by double-clicking on it.  

3. Now select the " Alarm mapping" tab. Under "Existing mappings" in the upper part of this 
pane, you can see links that have already been created. 

4. To add a new mapping, select the required group from "Group" in the lower part of the 
window. 

5. In the next step, depending on the device components, enter a hexadecimal value (00 to 
FF) in the "Value" box for the 7-segment display or select the color of the LED display. 
Select the "Flashing" box if you want the LED display to flash. 

6. Now confirm the mappings with the "Add" button. 

7. Exit the window with "OK". 

To cancel an alarm mapping, follow these steps: 

1. Change to the "Alarm mapping" tab as described above. 

2. Select the mapping you want to cancel from "Existing mappings". 

3. Click the "Remove" button. 

4. Exit the window with "OK". 
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6.11 Configuring the watchdog 
The monitoring function "Watchdog" (device-specific) allows you to check whether a station 
is still operational. 

The watchdog can be enabled or disabled ("Enable watchdog" option). If the watchdog is 
enabled, it will be called up repeatedly at the times set under "Interval." The "Reset on" 
option indicates whether a hardware reset will be performed when the watchdog is run (for 
example, if the operating system crashes or the PC cannot be operated). 

 

 Note 
Alarms 

An alarm is triggered if the watchdog cannot be triggered within the specified interval. See: 
Display of Alarms (Page 44). 

 

Configuring the watchdog  
1. Select the "Monitoring" group in the tree view of the Management Explorer. 

2. In the list view in the right-hand pane of the window, select the watchdog by double 
clicking on it.  

3. In the "Timeout value" box, you can set the time after which the activated watchdog is 
restarted. 

4. In the field "Software delay", a time delay for running the reset type (e.g. restart) can be 
set. 

5. Select the "Operation: on" box to enable the watchdog. 

6. Select the type of reset. The following options are available for your selection: 

– "Reset on" if you want a hardware reset to be performed if the watchdog times out. 

– "Reset off" results in no action when the watchdog times out. 

– "Restart" results in rebooting the operating system action when the watchdog times 
out. 

– "Shutdown" results in shutting down the operating system action when the watchdog 
times out. 

 
  Note 

The "Reset type" property depends on the device and its setting options are limited. 
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6.12 Configuration of hard disk space monitoring 
DiagMonitor Management Explorer offers the option of defining limits for disk space 
utilization for the partitions of a hard disk. As soon as the defined limit has been exceeded, 
this is displayed in the Management Explorer. 

Proceed as follows to define a limit for the disk space utilization: 

1. Select the "Hard disk" group in the tree view of the Management Explorer. 

2. In the list view, in the right pane of the window, select the required hard disk by 
doubleclicking on it. 

3. Select the required partition, e.g. "C". 

4. Set the required limit as a percentage value and click on "Apply". 

6.13 Reading the properties of a registered application 
You can display the properties of a registered application. 

Requirement 
The application whose properties you wish to display must have been registered beforehand 
with the Watchdog. Only applications created with the DMAPI library can be registered. You 
will find the DMAPI library in the corresponding directory after the installation of SIMATICIPC 
DiagMonitor. 

Procedure 
1. Select the "Monitoring" group in the tree view of the Management Explorer. 

2. Select the "Applications" group in the list view in the right-hand pane of the window. 

3. A list of the applications registered for this station will appear. 

4. Double-click on the application whose properties you wish to display. 

The properties of the application are displayed. 
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6.14 Changing the settings of the Management Explorer 
To change general settings of the DiagMonitor Management Explorer, select the "Tools" 
menu and then "Settings...". Here, you can then make the following settings:  

● Confirm program exit: If this box is selected, an additional confirmation window appears 
when you close the Management Explorer. 

● Start with Windows: Specifies whether or not the Management Explorer opens 
automatically when you start Windows. 

● Start delay: The Management Explorer requires several services to start. If the program is 
started with Windows, it may be possible that not all of these services are available yet. 
Here you can enter a start delay in seconds to ensure that all required services will have 
been started. 

● Minimize to...: The program window can be minimized to the taskbar or to the system 
tray. 

6.15 Starting the Alarm Manager from the Management Explorer 
The Alarm Manager can be called directly from the Management Explorer either to restart it 
or to change the settings. To open the Alarm Manager, select "Tools > Alarm Manager" in 
the Management Explorer menu.    

6.16 The Alarm Display 
The DiagMonitor alarm display lists all current local alarms that have occurred so that they 
can be acknowledged. The date and time at which the alarm occurred are also displayed. 
The lower part of the window displays a general message text. Here, for example, you might 
find information on what to do next and the phone number of a service technician.   

See also 
Changing the message text of the Alarm Display (Page 20) 



Description of the DiagMonitor Management Explorer  
6.17 Acknowledging alarms with the Alarm Display 

 SIMATIC IPC DiagMonitor 
20 Operating Manual, 08/2016, A5E38809569-AA 

6.17 Acknowledging alarms with the Alarm Display 
First, start the Alarm Display. You can do this by right-clicking on the Alarm Manager icon in 
the system tray. Select "Acknowledge all alarms" there.  

6.18 Changing the message text of the Alarm Display 
You can make settings in the DiagMonitor Alarm Manager so that the Alarm Display starts 
whenever an alarm occurs. The Alarm display window lists all alarms that have occurred so 
that they can be acknowledged. A general message text is also displayed in the lower part of 
the window. To change this text, select the "Tools" menu in the Management Explorer. If you 
then select "Alarm display...", an input box opens in which you can edit the message. 

6.19 Displaying events with the Event Viewer 
Events such as the occurrence and acknowledgment of an alarm can be logged. To be able 
to use this function, "Event logging" must be enabled in the settings of the Alarm Manager 
(see Changing settings of the Alarm Manager (Page 23)).  

1. Right-click in the tree view (left pane of the Management Explorer program window). 

2. Now select "Start event log". The Event Viewer program window opens. 

3. In the tree view in the left-hand pane, select the "Application" entry in the "Event Viewer". 
The list view in the right-hand pane then shows all the entries logged by Windows. 
SIMATIC IPC DiagMonitor software entries have the name "SIMATIC Diagnostic 
Management" in the "Source" column. 

4. If you double-click on an entry, you will see further information displayed. 

6.20 The Alarm Manager 
The DiagMonitor Alarm Manager is used to assign alarms to applications when they occur. 
If, for example, a fault develops in a RAID hard disk array, the Intel® Rapid Storage 
Technology (RST) program can be assigned to this fault (assuming it is installed). If a hard 
disk fault occurs, the Intel® Rapid Storage Technology (RST) software opens.  

6.21 Start Alarm Manager 
After installation, the Alarm Manager is configured so that the application is started 
automatically when the system starts up. You disable this feature as follows: 

1. You can do this by right-clicking on the Alarm Manager icon in the system tray. 

2. Select the menu command "Settings..." from the shortcut menu. 

3. Select the functions under "Autostart" in the "Options" tab. 

4. The Alarm Manager can continue to be started manually via the Management Explorer 
under "Options > AlarmManager...". 

The application prevents itself from being started more than once.  
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6.22 The Alarm Manager in the system tray 
If the Alarm Manager has been started, an icon appears in the system tray. There are three 
different representations depending on the status:  

● Connection established, no alarm  : The Alarm Manager is working correctly, a 
connection was established to the monitored devices. There are currently no problems to 
report. 

● Connection established, alarm  : The Alarm Manager is working correctly, a problem 
has been detected. When the alarm is cleared, the icon changes back to a DiagMonitor 
icon  . 

● Could not establish connection to at least one station  : In this state, only alarms from 
stations that have been successfully connected are reported. Ensure that the stations 
meet the requirements (Page 9) of the SIMATIC IPC DiagMonitor software. 

6.23 The "Alarm Manager - Settings" Window 
The "Settings" window of the Alarm Manager has two tabs:  

● Applications: Manages the applications, see Adding a new application in the Alarm 
Manager (Page 21) , Changing an application in the Alarm Manager (Page 22) , 
Removing an application in the Alarm Manager (Page 22). 

● Options: Makes it possible to change general settings, see Changing settings of the 
Alarm Manager (Page 23). 

6.24 Adding a new application in the Alarm Manager 
In the Alarm Manager, you can assign function groups to any application. To add a new 
application, follow these steps:  

1. You can do this by right-clicking on the Alarm Manager icon in the system tray > 
"Settings...". Open the "Applications" tab. 

2. Select a group from the "Possible groups" selection box. An alarm from this group will 
start the application. 

3. Using the ">" or "<" buttons, you can add or remove a group in "Selected groups". With 
">>" or "<<", you can add or remove all groups. 

4. Now enter a title below this for the new application. 

5. Select the storage location of the application with the "Browse..." button. 

6. Use the "Stations..." button to select the stations for which the application should be run 
when alarms occur. 

7. You can start the new application by right-clicking on the Alarm Manager icon in the 
system tray. This is only possible if you have selected the "Enter in shortcut menu" check 
box. 

8. You save the new application with the "Add" button. 
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6.25 Changing an application in the Alarm Manager 
To change the details of an application, follow these steps: 

1. Select the required application. 

2. Make these changes: See Adding a new application in the Alarm Manager (Page 21), 
items 2 to 6. 

3. You can save the changes with the "Change" button.  

6.26 Removing an application in the Alarm Manager 
If you want to remove an application, follow these steps: 

1. Select the required application. 

2. Click the "Remove" button. 

3. Confirm the "Delete entry?" prompt in the dialog with "Yes". 

6.27 Acknowledging alarms with the Alarm Manager 
The Alarm Manager offers the option of acknowledging alarms just like the Management 
Explorer. The Alarm Manager, however, acknowledges all alarms at the same time. It is not 
possible to acknowledge a specific alarm: 

1. You can do this by right-clicking on the Alarm Manager icon in the system tray. 

2. Select "Acknowledge all alarms". 
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6.28 Changing settings of the Alarm Manager 
Proceed as follows to make general settings of the Alarm Manager: 

1. You can do this by right-clicking on the Alarm Manager icon in the system tray. 

2. Select "Settings..." 

3. Change to the "Options" tab. Here, you can then make the following settings: 

– Acoustic alarm signal: 

An acoustic alarm can be output via the sound card. 

– Event logging: 

Events can be logged. Activate this function to save events in the event log.  

Refer to Displaying events with the Event Viewer (Page 20). 

– Autostart: 

Specifies whether or not the Alarm Manager opens automatically when you start 
Windows.  

6.29 Adding a station 
Stations can be added for monitoring in the station list of the Management Explorer. You can 
perform this as follows:  

● Using the menu command "Station > Add" or 

● by clicking the [*] button in the toolbar 

You can add a station from the "Add Station" dialog window as follows: 

1. Enter a name of a station which can be reached in the network. 

2. Press the "Find..." button to easily look for a station in the network. 

3. If you select the checkbox for "Local station", the local PC is automatically added in the 
program. 

The number of stations to add is unlimited. All added stations are observed and monitored at 
the same time.  

6.30 Removing a station 
To remove a station from the station list of the Management Explorer, you first have to select 
the given station; you can then remove the station as follows from the station list.  

● Using the menu command "Station > Remove" or 

● by clicking the [x] button in the toolbar.  
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6.31 Grouping stations 
Added stations can be assigned to a group. This enables the logical assignment of stations. 

Adding a group 
1. Right-click on a station. 

2. Select "Add station group". 

3. Enter a name for the group. 

4. Confirm the next dialog. 

The station is now found in the newly created group. 

Moving a station to a group 
1. Select a station and, keeping the mouse button pressed, drag-and-drop it on the required 

group. 

The station has now be moved to the required group. 

Removing groups 
1. Right-click on a group. 

2. Select "Remove group". 

The group has now been removed. 

6.32 Saving stations and groups 
The added station and groups can be saved to a file and loaded from a file. 

Saving stations 
Select "File > Stations > Save..." in the Management Explorer. 

Downloading stations 
Select "File > Stations > Load..." in the Management Explorer. 
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6.33 Email options 
The DiagMonitor Management Explorer allows you to have e-mails sent automatically in the 
event of an alarm, for example to maintenance personnel.  

Start the Management Explorer and select the menu command "Options > Email..." or click 
on the corresponding icon [Email tool] in the toolbar. 

The "Email Options" dialog window appears with the following two tabs:  

"Recipient" tab 
This allows you to create a standard email to be sent in the event of an alarm. 

1. Select the "Email notification" check box. 

2. Enter the recipient, the subject and the body of the email text in the appropriate fields. 
Use macros for the specific or variable parameters station, date, time and reason for the 
alarm. For more information, go to: Using macros in e-mail and SMS notification 
(Page 28) 

3. Click the "Test" button to perform a trial send attempt. 

"SMTP Server" tab 
You first have to configure the SMTP server to be able to send emails. The entered server 
data are stored or retained for future email transmission. We recommend checking the 
server settings prior to initial operation.  

1. Server information 

The necessary settings are specified by the network provider. 

– "Description" field: Enter a name for the SMTP server here. You can assign a name 
yourself. 

– "Server" field: Enter the server address here. 

– "Port" field: Enter the port here. 

The encryption methods TLS and SSL are available for email encryption. The default 
port for TLS is 587 and the default port for SSL is 465. 

If you do not want to send encrypted e-mails, select "n/a". 

2. Security: 

Enter the authentication data for your email account under network provider. 

– "Sender" field: Enter the sender for the SMTP server under network provider. 

– "User name" field: Enter the user name of your email account under network provider. 

– "Password" field: Enter the password of your email account under network provider. 
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3. POP3: 

There is the option for performing authentication by logging on via the POP(3) server and 
then sending email via SMTP server. This procedure is called "SMTP-After-POP" or 
"POP-Before-SMTP". 

With "SMTP-After-POP", the user first accesses its mailbox on the mail server via the 
POP3 protocol and thereby provides authentication with their user name and associated 
password. A defined time window then remains for sending e-mail per SMTP. The 
successful POP3 authentication, for example "pop.adresse.de", is used here for 
authorization for sending per SMTP. 
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6.34 SMS options 
The DiagMonitor Management Explorer allows you to have text messages sent automatically 
in the event of an alarm, for example, to maintenance personnel.  

Start the Management Explorer and select the menu command "Options > SMS..." or click 
on the corresponding icon [SMS tool] in the toolbar. 

The "SMS settings" dialog box appears. 

To create a standard SMS to be sent automatically in the event of an alarm, proceed as 
follows: 

1. Select the SMS notification check box. 

2. Select the appropriate virtual communication port for the data transmission. The virtual 
COM port to be used will only be displayed once you have installed the communication 
software provided with your cell phone. The cell phone can also be connected to a USB 
port. 

3. Enter the telephone number of the recipient who should be informed when a given alarm 
occurs. 

4. Write the text to be transmitted. Use macros for the specific or variable parameters 
station, date, time and reason for the alarm. You can find more information at: Using 
macros in e-mail and SMS notification (Page 28) 

5. Click the "Test" button to perform a trial send attempt. 

Once the configuration is successfully completed, a text message is sent to the cell phone if 
an alarm occurs. 

Comment: 

The SMS from SIMATIC IPC DiagMonitor can only be sent to devices that support GSM. 



Description of the DiagMonitor Management Explorer  
6.35 Using macros in e-mail and SMS notification 

 SIMATIC IPC DiagMonitor 
28 Operating Manual, 08/2016, A5E38809569-AA 

6.35 Using macros in e-mail and SMS notification 
Macros are available for e-mail and SMS notification. The current value at the time the alarm 
is triggered will then be inserted in place of the macros. Macros are available for the 
following specific or variable values: 

● Station 

Macro: %STATION% 

● Date 

Macro: %DATE% 

● Time of the alarm 

Macro: %TIME% 

● Reason for the alarm 

Macro: %REASON% 

Example 
● Event that triggers an alarm: 

There was a fan failure at station "IPC847D" at 11:00 on May 17, 2016. 

● Prepared text under the menu item Options > Email ....: 

%DATE%, %TIME%: Alarm at station %STATION%. %REASON%. 

● Text in the e-mail which is sent automatically: 

May 17 2016, 11.00: Alarm at station IPC847D. The low alarm limit for fan 0 (housing 
(front)) has been violated. 
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6.36 SNMP options 
Here you can set the time intervals for management station's SNMP communication to the 
computers to be monitored. 

SNMP (an acronym of "Simple Network Management Protocol") controls communication 
between the monitored devices and the monitoring station.  

Select the menu item "Tools > SNMP...". The dialog window "SNMP settings..." opens, in 
which you will find the following two groups: 

● "Time response" group: 

– In the "Feedback interval" window enter the time interval in which the monitoring data 
should be sent to the management station. 

– You can specify a timeout for the connection attempt in the "Timeout" window. 

– The "Redial attempts" window shows the number of attempts permitted to establish a 
connection. 

● "Connection" group: 

– In the "Community" window you can set the name of the SNMP community to which a 
connection is to be made. 

6.37 Revisions 
You can determine the number of hours the device has been in operation from the 
"Operating hours" group and also define custom revision alarms.  

All previously defined revisions are listed in the right window of the Management Explorer. 
After selecting the symbol of a revision, you can change the properties of this revision by 
right-clicking: 

● "Title" window: 

Shows the name of revision in the Revisions group. 

● "Alarm at" window: 

When these specified operating hours are reached, an alarm is triggered. 

● "Alarm in" window: 

An alarm is triggered if the number of operating hours equal the number of operating 
hours already accumulated plus the operating hours specified in this field. 

● "Interval" window: 

A cyclic alarm is triggered when the specified time has expired once this option is 
activated. 

Revisions can be added or removed at any time without restriction. 
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6.38 Monitoring Windows tasks 
In the "Monitoring > Applications" group, you can add tasks from Windows Task Scheduler to 
monitoring. 

All the tasks monitored up to this point are found in the right window of the Management 
Explorer. 

Adding task monitoring 
 

 Note 

Task monitoring can only be added for the local station. 
 

1. Right-click on "Monitoring > Applications". 

2. Select "Add" from the shortcut menu. 

The following settings can be made in the following dialog: 

● Title: 
Select the tasks to be monitored via "Browse...". 

 
  Note 

Only tasks which were created in the Windows Task Scheduler in the "DiagMonitor" 
folder can be monitored. 

 

● Path: 
Absolute path of task in the Windows Task Scheduler. 

● Return value for alarm: 

Here, enter the return values of the task for which an alarm is to be generated. Separate 
several values with a semicolon, e.g.: "1;2". 

● Return values without alarm: 
Here, enter the return values of the task for which no alarm is to be generated. Separate 
several values with a semicolon, e.g.: "0;3". 

● Start task every x seconds: 
Set this option if DiagMonitor should trigger the task every x seconds. The task can also 
be triggered via the task configuration in the Windows Task Scheduler. 

● Alarm for unknown values: 
Set this option if an alarm should be generated for unknown return values which were not 
entered previously.  

Removing task monitoring 
1. Right-click on "Monitoring > Applications". 

2. Select the task monitoring to be deleted on the right side. 

3. Right-click on the required element. 

4. Select "Remove" in the shortcut menu. 
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6.39 Service mode 
In addition to the states described under Interpreting the Status Information in the 
Management Explorer (Page 15) a station can have in the DiagMonitor, there is another 
state: the service state. 

Using the service mode, a station can be temporarily removed from monitoring. To do this, 
you need to select the corresponding station. You can then right-click to put this station into 
service mode or bring it back into monitoring. Alternatively, you can active or deactivate 
service mode using the "Computer tool" button. The computer symbol is not active in 
maintenance mode.  

6.40 Connection error 
In the event of the failure of the network or network disruptions, a connection error on a 
station is indicated by a small cross on the computer icon of the station.  

This marking disappears at the corresponding computer icon once the problem has been 
corrected. 

6.41 Set notifications for termination of connection 
1. Select "Options > Notifications…". 

In the following dialog, you can select the following messages with which you wish to be 
informed when a connection of a station is interrupted: 

● Event Log 

● E-mail (only if configured beforehand) 

● SMS (only if configured beforehand) 
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6.42 OPC server options 
OPC (OLE Process Control) is a technology for exchanging and using shared data between 
a range of applications. OPC has a variety of substandards that have been independently 
implemented for specific usage cases. OPC can thus be used for realtime monitoring, data 
archiving, alarming and for the latest application, controlling (instruction transmission).  
Industry PCs can use the OPC functionality of the SIMATIC IPC DiagMonitor to transmit 
monitoring data to SIMATIC applications. Each SIMATIC station can be viewed as an 
OPC DA client. OPC client functionality enables you to transfer data from SIMATIC IPC 
DiagMonitor to a different OPC application, for example: 
● SIMATIC WinAC 

● SIMATIC WinCC/WinCC flexible 

● SIMATIC NET 

The data can be visualized for the specific application using these programs. 
An OPC server is required to integrate the SIMATIC IPC DiagMonitor data into a SIMATIC 
application. The OPC server can be located on the same computer as the monitoring station 
or on a dedicated computer. 
Select the menu command "Options > OPC Server..." or simply press the corresponding 
button "OPC server tool" in the toolbar. The "OPC Server Configuration" dialog window 
appears, in which you can configure the OPC functionality:  
1. Computer name: Enter the name of the PC for which you know that an OPC server 

installed there is active. You can alternatively search for the PC using the "Browse" 
button. 

2. OPC server: Enter the name of the OPC server. If the OPCEnum service has been 
started on the server and the current user has access permissions for this service via 
DCOM, a list of installed OPC servers can also be displayed using the "Browse" button.  

3. Group name: Here you can specify the group within which the OPC tags should be 
created. 

4. Logon information: A user account is often required to successfully connect to an 
OPC server. If you activate the "Log on with another user" function and enter the user 
name, domain and password, this information will be used to log on to the OPC server. 

5. Templates: You can specify templates for the tag names in this dialog. They are used to 
save time renaming tags when the OPC server expects a certain name format. Enter the 
desired name in the selection list to create a new template. In the field below, you can 
create the name template. Certain character strings, such as "%s", will be replaced by the 
station name. The format of the tag must match the formats defined on the OPC server. 
You can select a separate template for each server. 

Apply your settings and confirm with "OK". The selected servers are shown in the right group 
window.  
The assignment or addition of tags is described in the section OPC Tags Assignment 
(Page 33). You can use the "Tags" button (see OPC Tag List (Page 33)) to display the tags 
monitored on the server. 

Saving and loading the configuration 
In the "Configuration" field, you can save the current OPC client configuration as well as the 
configuration of the tag assignment to a file or load them from a file.  
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6.43 OPC tag assignment 
After selecting a station or one of the element groups below it, you can right-click and select 
the "OPC..." option to open the dialog window for configuring OPC tags. There you can 
select tags for transmission to the OPC server previously selected.  

The displayed window is divided into two groups.  

"DM" group: 

● In the upper section of the window you will find the name of the previously selected group 
or station. For example, there are two fans, Fan[0] power supply fan and Fan[1] 
processor fan in the "Fans" group. 

● The lower section of the window shows all the properties of the selected elements. The 
OPC type and a brief description are provided in addition to the name. The selection of 
the tags to be transferred is made by setting a check mark and then confirming it with the 
right arrow symbol. If you want to change the tag names, click once right on the 
corresponding tag and enter the new name. 

"OPC" group: 

● The upper window displays the selected OPC server where the tags are to be transferred 
(see OPC Server Options (Page 32)). 

● The lower window lists the tags to be transferred to the corresponding OPC server. If you 
wish to remove an element from the list, use the left arrow symbol to do so. You can use 
the right arrow symbol to add an element. 

6.44 OPC Tag List 
Press the "Tags" button to get an overview of all tags to be transferred to the OPC server. 

The left group window shows the data of the connected OPC server and the group; the right 
window lists all of the OPC tags. The corresponding station of the tags is clearly indicated in 
addition to the name of the tags.  

You can remove the unused tags from the list by pressing the "Remove Tag" button.   
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6.45 Self-test 
You can use the DiagMonitor Management Explorer to perform a self-test for individual fans 
or all fans. This is used to determine if the maximum speed of the fans is sufficiently high to 
ensure trouble-free operation.  

After selecting a fan or the Fans group, you can open the properties dialog with a right-click. 
Open the "Self-test" tab. 

● "Title" window: 

Specifies the name of the self-test as shown in the Revisions group. 

● "Alarm at" window: 

When these specified operating hours are reached, the self-test is started and an alarm is 
triggered. 

● "Alarm in" window: 

An alarm is triggered if the number of operating hours equal the number of operating 
hours already accumulated plus the operating hours specified in this field. 

● "Silent alarm" window: 

Activate this option when no alarm should be triggered when the self-test is performed. 
This will not prevent an alarm for a wear limit defined by the manufacturer. 

● "Interval" window: 

Once this option is activated, a cyclical self-test is triggered after the specified time has 
expired. 

● "Test now" button: 

A self-test of the affected fans is started immediately when this button is pressed. 
 

  Note 

It is not possible to perform a self-test for all fans or in all devices. 
 

6.46 OPC UA server 
The OPC UA server makes information about the industry protocol OPC UA available.  

Make sure that these ports have been enabled in the firewall of your operating system. For 
further information on the configuration of the OPC UA server, refer to the included 
documentation, see installation directory. 

Following installation, you can start and stop the OPC UA server via the Management 
Explorer. For additional details, see Starting or stopping the OPC UA server (Page 35). 
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6.47 Starting or stopping the OPC UA server 
1. Open the Management Explorer. 

2. Select "OPC UA" from the "Options" menu. 

6.48 MiniWeb Server 
The MiniWeb server provides information on the system via HTTP/HTTPS. 

Make sure that these ports have been enabled in the firewall of your operating system. For 
additional information on changes, see Changing the MiniWeb Network Port (Page 35). 

Following installation, you can start and stop the MiniWeb server via Management Explorer. 
For additional details, see Starting and stopping the MiniWeb server (Page 35). 

6.49 Starting and stopping the MiniWeb server 
1. Start the Management Explorer. 

2. Select "Web server" from the "Options" menu. 

6.50 Changing the MiniWeb Network Port 
The default values for the network ports are 5009 for HTTP and 5449 for HTTPS. If you want 
to change the setting, follow these steps:  

1. Start the link "Start > Programs > Siemens Automation > DiagMonitor > WebServer > 
Configuration". 

2. Search for the line <PORTNUMBER VALUE="5009"/>. 

3. Change the value of the respective http port. 

4. Search for the line <SSLPORTNUMBER VALUE="5449"/>. 

5. Change the value of the respective HTTPS port. 

6. Save and close the file. 

7. Restart the MiniWeb service (see Starting and stopping the MiniWeb server (Page 35)). 

 



Description of the DiagMonitor Management Explorer  
6.51 Opening the MiniWeb Site 

 SIMATIC IPC DiagMonitor 
36 Operating Manual, 08/2016, A5E38809569-AA 

6.51 Opening the MiniWeb Site 
If the MiniWeb service has been started (see Starting and stopping the MiniWeb server 
(Page 35)), you can open the website using a browser. If you want to open the website of the 
local computer, enter the following address in the address line of the browser: 
http://localhost:5009 or https://localhost:5449. If you want to open the website of another 
computer: http://computer name:5009  or http://IP address of the computer:5009. Make sure 
that the firewall of your operating system has been configured so that you can access the 
respective port.  

6.52 Changing the Links on the MiniWeb Site 
The MiniWeb site displays different Internet links to Siemens support sites in the menu item 
"Links“. If you want to change or add links at a later time, follow these steps:  

1. Start the link "Start > Programs > Siemens Automation > DiagMonitor > WebServer > 
Links". 

2. If you want to add a new link, open the links as an administrator (right-click), copy one of 
the lines and change it as necessary. 

"NAME =“ is the displayed name, "TARGET=“ the link to the target address. 

3. Save and close the file.  

6.53 "Temperatures" Group 
The "Temperatures" group indicates the status of the existing temperature sensors (device-
dependent).  

The temperature will be displayed in a thermometer symbol, depending on the view. 

● The unit is °C (Celsius) for metric settings 

● The unit is °F (Fahrenheit) for Anglo-American settings 

Proceed as follows to change this setting:  

1. Start the country setting in the Control Panel. 

2. You select the measuring system in the "Numbers" tab under "Measuring system." 

3. Re-start Management Explorer. 

The last temperature measurement is displayed below the thermometer symbol. To the left 
of the temperature scale are the minimum and maximum allowed values. Violation of these 
limits will trigger an alarm. To the right of the temperature scale are the minimum and 
maximum measured values. 

Alarms 

If the temperature exceeds or falls below the specified maximum or minimum value, this is 
displayed in the status of the sensor (see Display of Alarms (Page 44) ). 
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6.54 "Fan" Group 
The "fan" group indicates the status of the existing fans (device-dependent).    

The fan speed is represented in a fan symbol, depending on the selected view; all speeds 
are indicated in revolutions per minute. The last speed measurement is displayed below the 
fan symbol. To the left of the speed scale are the minimum and maximum allowed values. 
Violation of these limits will trigger an alarm. To the right of the speed scale are the minimum 
and maximum measured values. 

Alarms 

If the speed falls below the indicated minimum value, such a reaction will be displayed in the 
sensor status (see Display of Alarms (Page 44)). 

6.55 "Voltages" Group 
The "Voltages" group indicates the status of the existing voltage sensors (device-
dependent).  

The voltage of a backup battery (CMOS), a redundant power supply (device-dependent) or 
an uninterruptible power supply (device-dependent) can be monitored. 

The backup battery voltage is monitored to establish whether it is ok, critical or faulty. 
 

 Note 
Backup battery (CMOS) 

Replace the backup battery immediately if the sensor indicates a critical or faulty status. 
 

Redundant power supply monitoring checks that both power inputs are enabled and the 
power supply unit fan is operating. 

With an uninterruptible power supply, monitoring checks whether the current input is active. 
 

 Note 
Alarms 

If the voltage falls below the indicated minimum value, the sensor status will indicate this. 
See Display of Alarms (Page 44)  
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6.56 "Hard disk" Group 
The "Hard Disk" group indicates the status of the existing hard disks (device-dependent). 
The following hard disks are supported:  

● SATA hard disks 

● CompactFlash cards 

● CFast cards 

● SAS hard disks 

● USB hard disks or USB sticks 

● Hard disks for an INTEL RAID adapter or Adaptec RAID adapter 

The properties for each drive indicate if the drive is S.M.A.R.T. capable and/or a RAID drive. 
If this is the case, then the drive symbol is displayed actively with a symbolic LED. The type, 
serial number, and firmware version of the drive is displayed in the respective text box. 

Alarms 

If a drive reports a SMART or RAID error, the status of the drive changes (see Display of 
Alarms (Page 44)). 

SMART (Self-Monitoring, Analysis and Reporting Technology): 

All hard disks of the Industrial PC support SMART technology. 

SIMATIC IPC DiagMonitor requests a status report of the hard disk with special routines. 
The SMART hard disk keeps a list of errors that occurred during reading or writing of 
sectors. If the number of errors exceeds a certain threshold, this fact often indicates that the 
drive will become faulty soon. 

This is the time when you should create a backup of the drive and replace the hard disk. 

An example for this type of problem may be small particles in the disk housing that do not 
immediately result in a "Headcrash," but initially cause only scratches in the surface of the 
magnetic disk. This process results in more free particles. The number of errors increases 
and results in a "Headcrash". 

SMART would register the increasing number of errors and trigger an alarm in this case. 

SMART does, however, not detect problems that are caused by the electronics and result in 
an instant failure of the hard disk. 

6.57 "LEDs" group 
The "Displays" group indicates the status of the existing displays (device-dependent). The 
following displays are supported:    

● LED 

● Port 80 display 

The latest value of the display is always shown. It is possible to display a specific value in 
case of an alarm (see Mapping an alarm to a display (Page 16)). 
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6.58 "Monitoring" Group 
The following monitoring functions are available in the "Monitoring" group:  

● Watchdog 

You can register the applications of a station with the Watchdog. If an application then 
fails to report back to the Watchdog within the set time interval, the Watchdog will be 
triggered with the parameters set for the application in question. 

You can find addition information on this under: Configuring the watchdog (Page 17). 

If no applications have been registered, you can use the monitoring function Watchdog to 
check whether diagnostics management is still operational. 

● Applications 

You can use the "Applications" monitoring function to display the properties of an 
application. You can find addition information on this under: Reading the properties of a 
registered application (Page 18). 

● Tasks 

You can use the "Tasks" monitoring function to monitor tasks from Windows Task 
Scheduler. 

See also 
Display of Alarms (Page 44) 

6.59 "Operating Hours" Group 
The "Operating hours" group displays the elapsed operating hours of the device since the 
installation of the monitoring software. This value is not lost when you reinstall the monitoring 
software. This group is subordinate to the Revisions group (see Revisions (Page 29) ).  
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6.60 "BIOS" Group 
The subgroup is located in the "BIOS" group SMBIOS (Page 40).  

6.60.1 SMBIOS 
SMBIOS (System Management BIOS) specifies data structures, as well as their 
arrangement in the BIOS of the computer.  

All configuration data on the motherboard of the SIMATIC IPC device, such as the serial 
number, order number, revision numbers of the hardware or BIOS, device names, processor 
information or system information; can be displayed in the "SMBIOS" group. 

Only the group elements are shown in a tree under the "SMBIOS“ group in the left section of 
the Management Explorer. Both group elements and single elements are shown in the right 
section of the window. 

6.61 BIOS settings 
You can save the BIOS Setup settings of a PC in a file. This step saves the basic settings of 
a device so that you can restore the basic status of the BIOS Setup settings after inadvertent 
or incorrect changes.  

You can also transfer the BIOS settings from one computer to another if the hardware 
platform and the BIOS version match. This will give you the option to save the BIOS settings 
of a computer as a template. 

 

 Note 

The following functions vary according to the device and are not available on all 
SIMATIC IPC models. 

 

Saving the latest BIOS settings  
1. Start the Management Explorer. 

2. In the menu bar, select "Tools > Local BIOS...". 

3. Select the "Settings" tab. 

4. Click the "Save" button. 

5. Select the storage location and enter a suitable file name. 

6. Confirm the selection. 
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Upload BIOS settings  
1. Start the Management Explorer. 

2. In the menu bar, select "Tools > Local BIOS...". 

3. Select the "Settings" tab. 

4. Click the "Load" button. 

5. Select the file you want to upload. 

6. Confirm the selection. 

7. Activate the newly loaded BIOS settings by restarting the PC. 

Displaying current BIOS settings  
1. Start the Management Explorer. 

2. In the menu bar, select "Tools > Local BIOS...". 

The current BIOS settings are shown in the "Settings" tab. 
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6.62 BIOS version 
 

 Note 

The following functions will not be available on all SIMATIC IPC models. 
 

Assigning and changing inventory numbers  
You can assign inventory numbers to your devices or change assigned inventory numbers 
for internal administrative purposes. 

1. Start the Management Explorer. 

2. In the menu bar, select "Tools > Local BIOS...". 

3. Select the "Update" tab. 

4. Click the "Change" button in the "Inventory number" field. 

5. Assign a new inventory number or change an existing inventory number and confirm your 
entry. 

6. Restart the device. 

Result 

The inventory number is now permanently saved in the device SMBIOS. 

The inventory number is located in SMBIOS under "System Enclosure" as entry 
"Asset Tag Number". 
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Performing a BIOS update  
 

 Note 
Latest BIOS 

Check whether a current BIOS is available for your SIMATIC IPC. Additional information can 
be found on the Internet at Industry Automation and Drive Technologies - Homepage 
(http://www.siemens.com/automation/service&support). 

 

 Note 
Irreparable damages to the BIOS 

An incorrectly performed BIOS update may cause irreparable damages to the BIOS. You 
may only start a BIOS update if it is absolutely necessary. The following applies: 
• Never interrupt the power supply while an update is taking place. 
• The update process must be complete before you shut down the device. 

 

1. Start the Management Explorer. 

2. In the menu bar, select "Tools > Local BIOS...". 

3. Select the "Update" tab. 

4. Click the "Load" button in the "BIOS Image" field. 

5. Select the required binary file for the update. 

6. A version comparison will be carried out. 

7. Start the update. 

http://www.siemens.com/automation/service&support
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6.63 Display of Alarms 
 

Alarms are represented by the status for each element, each group and each station. The 
possible alarm states of a status are described in the following:  

● Ok 

No error has occurred. The objects with this status are displayed in the Management 
Explorer in the colors gray and blue. 

This status cannot be acknowledged. 

● Alarm 

An error has occurred which is still present at this time, e.g. fan standstill. The objects 
with this status are displayed in the Management Explorer in the color red. 

If this status is acknowledged, the status will change to "Acknowledged Alarm". 

● Acknowledged Alarm 

An error has occurred that is still present, such as a fan standstill, but that has been 
acknowledged in the meantime. The objects with this status are displayed in the 
Management Explorer in the color red. 

This status cannot be acknowledged again. If the reason for the alarm has been 
removed, the status will automatically change to "Ok". 

● Outgoing alarm 

If an error has occurred that is not present currently, such as a fan that came to a 
standstill but is running now. The objects with this status are displayed in the 
Management Explorer in the color yellow. 

If this status is acknowledged, the status will change to "Ok". 
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 Diagnostics data via Windows Performance 
Counters 7 
 

 

Windows Performance Counters is a system tool from Windows, which provides measured 
values for monitoring system performance. These measured values can be determined and 
visualized either via the Performance Counters API or with Performance Counters 
applications (e.g.: "Windows Performance Monitor"). 

SIMATIC IPC DiagMonitor makes the following Performance Counters available: 
 
Counters Description 
SIMATIC DiagMonitor disks   
Alarm count Number of hard disk alarms in the current session 
SIMATIC DiagMonitor fans   
Alarm count Number of fan alarms in the current session 
Current value Current fan speed in rpm 
SIMATIC DiagMonitor tem-
peratures 

  

Alarm count Number of temperature alarms in the current session 
Current value Current temperatures in °C 
SIMATIC DiagMonitor volt-
ages 

  

Alarm count Number of voltage alarms in the current session 

The Windows Performance Counters can be monitored, for example, using the Windows 
application "Windows Performance Monitor". 
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